MY 1999 GRAND MOVE HAS NO WORKING HORN...ANY HELP PLEASE

Forum: 

Help Can anyone out there suggest anything please...? My horn on the above model is not working, I was hoping it was just a fuse, but my hazard lights are working, i have double checked them, (as it states in my handbook that it is the same fuse..) can anyone else suggest what it may be, I think it is illegal for its mot which is due shortly and want to sort it out...dont want it failing just due to a horn fault... I rarely use the thing, and cant remember the last time i did, cannot think why it is not working, dont think i have done anything to it...? so i am baffled, please help..? Scratch one-s head

It may be a dirty contact on

It may be a dirty contact on the horn it self, or the earth on the stearing columb has corroded up.

Any veiws expresed in this thread by me are purely from my own experience, and (sometimes) falible memory. Hope my comments help, but please don't take them as gospel.

Any veiws expresed in this thread by me are purely from my own experience, and (sometimes) falible memory. Hope my comments help, but please don't take them as gospel.

Horn - Horns.

2003 Sirion Rally 4. And I love it.
Don't like the new shape Sirion much.Sorry.

Have you checked there is power to the Horn.
You should just be able to put a 12v bulb between the wires and press the Horn Button and see if it lights up.
If it does - You can get an aftermarket horn from any decent Car Parts Shop.

Just replace the faulty Horn - As they say these Days - SIMPLES!!
But if you do need a Horn - Get some Dual Note Horns (A tenner at the most)
They sound better than the pathetic noise that most Daihatsu's make !! Smile

Do as in the other suggestion and check the Earths.It is always good to keep them cleaned up anyway.

Let us know how you go on.

Cheers, Bob F.

2003 Sirion Rally 4. And I love it.
Don't like the new shape Sirion much.Sorry.

Horn - secondary fuse under bonnet

Hi,

You may find that your Grand Move has a second fuse, under the bonnet which is NOT shared with the hazards (unlike the fuse found on the interior fuse box).

My Grand move has a 2nd dedicated 10 amp fuse, located "in-line" on a cable under the bonnet, located on the same side as the battery, and it's tethered with a clip, just by the cooling fluid reservoir, on the mount for the suspension strut.

Odd that it's not mounted in the under-bonnet fuse box - but there you go!

(You may find a spare fuse in the under bonnet fuse box)

Let us know how you get on.

My horn problem

Thanks for your suggestions guys, I am sorry I havent responded sooner, but I have had trouble logging on for some strange reason,...? anyhow...I havent had chance to check out the suggestions as yet, but will be doing this week, I will let you know how I get on with it, thanks again, you are really helpful and quick! Smile